阿里云服务器Centos7系统上搭建typecho博客

这个阿里服务器被我删除根目录后,博客也就无法安心地住在这儿了,重置系统后,重新安装typecho博客,上次安装了一天的过程这次也还是花了一两个点,一步一步来都会遇见问题,来看看有惊无险的整个过程吧~

安装教程大致按照此处‘1’

途中遇到若干问题:


  1. 无法访问apache

    • 问题描述:

      无法通过ip:80访问apache服务器

    • 问题解决:

      1. 关闭防火墙

        1
        systemctl stop firewalld.service
      2. 配置Apache配置

        在/etc/httpd/conf/httpd.conf中,修改,找到被注释的这一行,并修改为如下:

        1
        ServerName  localhost:80
      3. 配置阿里云安全策略组
        配置安全组,不然会被阿里拦截


  1. 创建用户并为其分配数据库权限失败

    • 问题描述:

      按照教程的步骤走到此处出现问题:

      1
      2
      3
      创建一个普通用户并 赋予其typecho数据库的所有表的权限:
      mysql> grant all privileges on typecho.* to typcho@localhost identified by 'Test123/';//////////ERROR
      mysql> flush privileges;

      未过多探究其原因,估计是我安装的是mysql8,有很多命令变化了,便将这步拆解成创建用户、分配权限两部完成‘2’

    • 问题解决:

      1. 创建新用户:

        1
        2
        mysql> CREATE USER 'typecho'@'localhost' IDENTIFIED BY 'Password/';        //创建新用户
        mysql> exit //退出普通用户typecho
      2. 数据库授权给新用户:

        1
        2
        3
        mysql -u root -p     //登录root用户
        grant all privileges on typecho.* to 'typecho'@'localhost'; //授权
        flush privileges; //刷新

  1. typecho可视化安装配置时,无法连接数据库

    • 问题描述:

      typecho无法连接数据库,后查明是本人使用mysql8的缘故,从mysql8开始使用的加密方式为: caching-sha2-password,mysql workbench能识别的加密方式还是原来的:mysql_native_password,因此需要把mysql8的typecho用户的密码加密方式改为mysql_native_password。

    • 问题解决:

      1
      2
      ALTER USER 'typecho'@'localhost' IDENTIFIED WITH mysql_native_password BY 'Password/';        //更新一下用户的密码
      FLUSH PRIVILEGES; //刷新权限

  1. 开启站点伪静态时遇错

    • 问题描述:

      按照教程操作,结果还是无法出错:‘3’

    • 问题解决:
      傻逼错误,最后的忘了重启httpd服务以让改动生效了


安装日志

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
414
415
416
417
418
419
420
421
422
423
424
425
426
427
428
429
430
431
432
433
434
435
436
437
438
439
440
441
442
443
444
445
446
447
448
449
450
451
452
453
454
455
456
457
458
459
460
461
462
463
464
465
466
467
468
469
470
471
472
473
474
475
476
477
478
479
480
481
482
483
484
485
486
487
488
489
490
491
492
493
494
495
496
497
498
499
500
501
502
503
504
505
506
507
508
509
510
511
512
513
514
515
516
517
518
519
520
521
522
523
524
525
526
527
528
529
530
531
532
533
534
535
536
537
538
539
540
541
542
543
544
545
546
547
548
549
550
551
552
553
554
555
556
557
558
559
560
561
562
563
564
565
566
567
568
569
570
571
572
573
574
575
576
577
578
579
580
581
582
583
584
585
586
587
588
589
590
591
592
593
594
595
596
597
598
599
600
601
602
603
604
605
606
607
608
609
610
611
612
613
614
615
616
617
618
619
620
621
622
623
624
625
626
627
628
629
630
631
632
633
634
635
636
637
638
639
640
641
642
643
644
645
646
647
648
649
650
651
652
653
654
655
656
657
658
659
660
661
662
663
664
665
666
667
668
669
670
671
672
673
674
675
676
677
678
679
680
681
682
683
684
685
686
687
688
689
690
691
692
693
694
695
696
697
698
699
700
701
702
703
704
705
706
707
708
709
710
711
712
713
714
715
716
717
718
719
720
721
722
723
724
725
726
727
728
729
730
731
732
733
734
735
736
737
738
739
740
741
742
743
744
745
746
747
748
749
750
751
752
753
754
755
756
757
758
759
760
761
762
763
764
765
766
767
768
769
770
771
772
773
774
775
776
777
778
779
780
781
782
783
784
785
786
787
788
789
790
791
792
793
794
795
796
797
798
799
800
801
802
803
804
805
806
807
808
809
810
811
812
813
814
815
816
817
818
819
820
821
822
823
824
825
826
827
828
829
830
831
832
833
834
835
836
837
838
839
840
841
842
843
844
845
846
847
848
849
850
851
852
853
854
855
856
857
858
859
860
861
862
863
864
865
866
867
868
869
870
871
872
873
874
875
876
877
878
879
880
881
882
883
884
885
886
887
888
889
890
891
892
893
894
895
896
897
898
899
900
901
902
903
904
905
906
907
908
909
910
911
912
欢迎使用深度终端, 在您使用右键菜单进行上传和下载文件之前, 请先确保服务器已经安装了rz和sz命令。
[root@skyqin ~]# ls
[root@skyqin ~]# ls -il
总用量 0
[root@skyqin ~]# cd ~
[root@skyqin ~]# cd /
[root@skyqin /]# ls
bin boot dev etc home lib lib64 lost+found media mnt opt proc root run sbin srv sys tmp usr var
[root@skyqin /]# cd ~
[root@skyqin ~]# yum install httpd
已加载插件:fastestmirror
Determining fastest mirrors
base | 3.6 kB 00:00:00
epel | 5.4 kB 00:00:00
extras | 2.9 kB 00:00:00
updates | 2.9 kB 00:00:00
(1/7): base/7/x86_64/group_gz | 165 kB 00:00:00
(2/7): epel/x86_64/group_gz | 90 kB 00:00:00
(3/7): epel/x86_64/updateinfo | 1.0 MB 00:00:00
(4/7): extras/7/x86_64/primary_db | 153 kB 00:00:00
(5/7): base/7/x86_64/primary_db | 6.0 MB 00:00:00
(6/7): epel/x86_64/primary_db | 6.9 MB 00:00:00
(7/7): updates/7/x86_64/primary_db | 2.8 MB 00:00:00
正在解决依赖关系
--> 正在检查事务
---> 软件包 httpd.x86_64.0.2.4.6-90.el7.centos 将被 安装
--> 正在处理依赖关系 httpd-tools = 2.4.6-90.el7.centos,它被软件包 httpd-2.4.6-90.el7.centos.x86_64 需要
--> 正在处理依赖关系 /etc/mime.types,它被软件包 httpd-2.4.6-90.el7.centos.x86_64 需要
--> 正在处理依赖关系 libaprutil-1.so.0()(64bit),它被软件包 httpd-2.4.6-90.el7.centos.x86_64 需要
--> 正在处理依赖关系 libapr-1.so.0()(64bit),它被软件包 httpd-2.4.6-90.el7.centos.x86_64 需要
--> 正在检查事务
---> 软件包 apr.x86_64.0.1.4.8-5.el7 将被 安装
---> 软件包 apr-util.x86_64.0.1.5.2-6.el7 将被 安装
---> 软件包 httpd-tools.x86_64.0.2.4.6-90.el7.centos 将被 安装
---> 软件包 mailcap.noarch.0.2.1.41-2.el7 将被 安装
--> 解决依赖关系完成

依赖关系解决

======================================================================================
Package 架构 版本 源 大小
======================================================================================
正在安装:
httpd x86_64 2.4.6-90.el7.centos base 2.7 M
为依赖而安装:
apr x86_64 1.4.8-5.el7 base 103 k
apr-util x86_64 1.5.2-6.el7 base 92 k
httpd-tools x86_64 2.4.6-90.el7.centos base 91 k
mailcap noarch 2.1.41-2.el7 base 31 k

事务概要
======================================================================================
安装 1 软件包 (+4 依赖软件包)

总下载量:3.0 M
安装大小:10 M
Is this ok [y/d/N]: y
Downloading packages:
(1/5): apr-1.4.8-5.el7.x86_64.rpm | 103 kB 00:00:00
(2/5): apr-util-1.5.2-6.el7.x86_64.rpm | 92 kB 00:00:00
(3/5): httpd-tools-2.4.6-90.el7.centos.x86_64.rpm | 91 kB 00:00:00
(4/5): mailcap-2.1.41-2.el7.noarch.rpm | 31 kB 00:00:00
(5/5): httpd-2.4.6-90.el7.centos.x86_64.rpm | 2.7 MB 00:00:00
--------------------------------------------------------------------------------------
总计 13 MB/s | 3.0 MB 00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
正在安装 : apr-1.4.8-5.el7.x86_64 1/5
正在安装 : apr-util-1.5.2-6.el7.x86_64 2/5
正在安装 : httpd-tools-2.4.6-90.el7.centos.x86_64 3/5
正在安装 : mailcap-2.1.41-2.el7.noarch 4/5
正在安装 : httpd-2.4.6-90.el7.centos.x86_64 5/5
验证中 : apr-1.4.8-5.el7.x86_64 1/5
验证中 : mailcap-2.1.41-2.el7.noarch 2/5
验证中 : httpd-tools-2.4.6-90.el7.centos.x86_64 3/5
验证中 : apr-util-1.5.2-6.el7.x86_64 4/5
验证中 : httpd-2.4.6-90.el7.centos.x86_64 5/5

已安装:
httpd.x86_64 0:2.4.6-90.el7.centos

作为依赖被安装:
apr.x86_64 0:1.4.8-5.el7 apr-util.x86_64 0:1.5.2-6.el7
httpd-tools.x86_64 0:2.4.6-90.el7.centos mailcap.noarch 0:2.1.41-2.el7

完毕!
[root@skyqin ~]# systemctl start httpd
[root@skyqin ~]# systemctl status httpd
● httpd.service - The Apache HTTP Server
Loaded: loaded (/usr/lib/systemd/system/httpd.service; disabled; vendor preset: disabled)
Active: active (running) since 日 2019-11-03 12:38:54 CST; 14s ago
Docs: man:httpd(8)
man:apachectl(8)
Main PID: 1345 (httpd)
Status: "Total requests: 0; Current requests/sec: 0; Current traffic: 0 B/sec"
CGroup: /system.slice/httpd.service
├─1345 /usr/sbin/httpd -DFOREGROUND
├─1346 /usr/sbin/httpd -DFOREGROUND
├─1347 /usr/sbin/httpd -DFOREGROUND
├─1348 /usr/sbin/httpd -DFOREGROUND
├─1349 /usr/sbin/httpd -DFOREGROUND
└─1350 /usr/sbin/httpd -DFOREGROUND

11月 03 12:38:54 skyqin systemd[1]: Starting The Apache HTTP Server...
11月 03 12:38:54 skyqin httpd[1345]: AH00558: httpd: Could not reliably determin...ge
11月 03 12:38:54 skyqin systemd[1]: Started The Apache HTTP Server.
Hint: Some lines were ellipsized, use -l to show in full.
[root@skyqin ~]# systemctl enable httpd
Created symlink from /etc/systemd/system/multi-user.target.wants/httpd.service to /usr/lib/systemd/system/httpd.service.
[root@skyqin ~]# systemctl status firewalld
● firewalld.service - firewalld - dynamic firewall daemon
Loaded: loaded (/usr/lib/systemd/system/firewalld.service; disabled; vendor preset: enabled)
Active: inactive (dead)
Docs: man:firewalld(1)
[root@skyqin ~]# firewall-cmd --permanent --add-service=http
FirewallD is not running
[root@skyqin ~]# systemctl start firewalld
[root@skyqin ~]# systemctl status firewalld
● firewalld.service - firewalld - dynamic firewall daemon
Loaded: loaded (/usr/lib/systemd/system/firewalld.service; disabled; vendor preset: enabled)
Active: active (running) since 日 2019-11-03 12:42:06 CST; 15s ago
Docs: man:firewalld(1)
Main PID: 1386 (firewalld)
CGroup: /system.slice/firewalld.service
└─1386 /usr/bin/python -Es /usr/sbin/firewalld --nofork --nopid

11月 03 12:42:06 skyqin systemd[1]: Starting firewalld - dynamic firewall daemon...
11月 03 12:42:06 skyqin systemd[1]: Started firewalld - dynamic firewall daemon.
[root@skyqin ~]# firewall-cmd --permanent --add-service=http
success
[root@skyqin ~]# firewall-cmd --permanent --add-service=https
success
[root@skyqin ~]# cd /etc/httpd/conf/httpd.conf
bash: cd: /etc/httpd/conf/httpd.conf: 不是目录
[root@skyqin ~]# vim /etc/httpd/conf/httpd.conf
[root@skyqin ~]# systemctl status httpd
● httpd.service - The Apache HTTP Server
Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
Active: active (running) since 日 2019-11-03 12:38:54 CST; 13min ago
Docs: man:httpd(8)
man:apachectl(8)
Main PID: 1345 (httpd)
Status: "Total requests: 0; Current requests/sec: 0; Current traffic: 0 B/sec"
CGroup: /system.slice/httpd.service
├─1345 /usr/sbin/httpd -DFOREGROUND
├─1346 /usr/sbin/httpd -DFOREGROUND
├─1347 /usr/sbin/httpd -DFOREGROUND
├─1348 /usr/sbin/httpd -DFOREGROUND
├─1349 /usr/sbin/httpd -DFOREGROUND
└─1350 /usr/sbin/httpd -DFOREGROUND

11月 03 12:38:54 skyqin systemd[1]: Starting The Apache HTTP Server...
11月 03 12:38:54 skyqin httpd[1345]: AH00558: httpd: Could not reliably determin...ge
11月 03 12:38:54 skyqin systemd[1]: Started The Apache HTTP Server.
Hint: Some lines were ellipsized, use -l to show in full.
[root@skyqin ~]# systemctl stop firewalld
[root@skyqin ~]# ls
[root@skyqin ~]# mkdir mysql
[root@skyqin ~]# cd mysql
[root@skyqin mysql]# wget https://dev.mysql.com/get/mysql80-community-release-el7-3.noarch.rpm
--2019-11-03 13:01:40-- https://dev.mysql.com/get/mysql80-community-release-el7-3.noarch.rpm
正在解析主机 dev.mysql.com (dev.mysql.com)... 137.254.60.11
正在连接 dev.mysql.com (dev.mysql.com)|137.254.60.11|:443... 已连接。
已发出 HTTP 请求,正在等待回应... 302 Found
位置:https://repo.mysql.com//mysql80-community-release-el7-3.noarch.rpm [跟随至新的 URL]
--2019-11-03 13:01:42-- https://repo.mysql.com//mysql80-community-release-el7-3.noarch.rpm
正在解析主机 repo.mysql.com (repo.mysql.com)... 104.86.185.42
正在连接 repo.mysql.com (repo.mysql.com)|104.86.185.42|:443... 已连接。
已发出 HTTP 请求,正在等待回应... 200 OK
长度:26024 (25K) [application/x-redhat-package-manager]
正在保存至: “mysql80-community-release-el7-3.noarch.rpm”

100%[============================================>] 26,024 --.-K/s 用时 0.1s

2019-11-03 13:01:43 (200 KB/s) - 已保存 “mysql80-community-release-el7-3.noarch.rpm” [26024/26024])

[root@skyqin mysql]# rpm -ivh mysql80-community-release-el7-3.noarch.rpm
警告:mysql80-community-release-el7-3.noarch.rpm: 头V3 DSA/SHA1 Signature, 密钥 ID 5072e1f5: NOKEY
准备中... ################################# [100%]
正在升级/安装...
1:mysql80-community-release-el7-3 ################################# [100%]
[root@skyqin mysql]# yum repolist enabled |grep mysql
mysql-connectors-community/x86_64 MySQL Connectors Community 131
mysql-tools-community/x86_64 MySQL Tools Community 100
mysql80-community/x86_64 MySQL 8.0 Community Server 145
[root@skyqin mysql]# yum install mysql-community-server
已加载插件:fastestmirror
Loading mirror speeds from cached hostfile
正在解决依赖关系
--> 正在检查事务
---> 软件包 mysql-community-server.x86_64.0.8.0.18-1.el7 将被 安装
--> 正在处理依赖关系 mysql-community-common(x86-64) = 8.0.18-1.el7,它被软件包 mysql-community-server-8.0.18-1.el7.x86_64 需要
--> 正在处理依赖关系 mysql-community-client(x86-64) >= 8.0.11,它被软件包 mysql-community-server-8.0.18-1.el7.x86_64 需要
--> 正在处理依赖关系 libaio.so.1(LIBAIO_0.4)(64bit),它被软件包 mysql-community-server-8.0.18-1.el7.x86_64 需要
--> 正在处理依赖关系 libaio.so.1(LIBAIO_0.1)(64bit),它被软件包 mysql-community-server-8.0.18-1.el7.x86_64 需要
--> 正在处理依赖关系 libaio.so.1()(64bit),它被软件包 mysql-community-server-8.0.18-1.el7.x86_64 需要
--> 正在检查事务
---> 软件包 libaio.x86_64.0.0.3.109-13.el7 将被 安装
---> 软件包 mysql-community-client.x86_64.0.8.0.18-1.el7 将被 安装
--> 正在处理依赖关系 mysql-community-libs(x86-64) >= 8.0.11,它被软件包 mysql-community-client-8.0.18-1.el7.x86_64 需要
---> 软件包 mysql-community-common.x86_64.0.8.0.18-1.el7 将被 安装
--> 正在检查事务
---> 软件包 mariadb-libs.x86_64.1.5.5.60-1.el7_5 将被 取代
--> 正在处理依赖关系 libmysqlclient.so.18()(64bit),它被软件包 2:postfix-2.10.1-7.el7.x86_64 需要
--> 正在处理依赖关系 libmysqlclient.so.18(libmysqlclient_18)(64bit),它被软件包 2:postfix-2.10.1-7.el7.x86_64 需要
---> 软件包 mysql-community-libs.x86_64.0.8.0.18-1.el7 将被 舍弃
--> 正在检查事务
---> 软件包 mysql-community-libs-compat.x86_64.0.8.0.18-1.el7 将被 舍弃
--> 解决依赖关系完成

依赖关系解决

======================================================================================
Package 架构 版本 源 大小
======================================================================================
正在安装:
mysql-community-libs x86_64 8.0.18-1.el7 mysql80-community 3.7 M
替换 mariadb-libs.x86_64 1:5.5.60-1.el7_5
mysql-community-libs-compat x86_64 8.0.18-1.el7 mysql80-community 1.3 M
替换 mariadb-libs.x86_64 1:5.5.60-1.el7_5
mysql-community-server x86_64 8.0.18-1.el7 mysql80-community 429 M
为依赖而安装:
libaio x86_64 0.3.109-13.el7 base 24 k
mysql-community-client x86_64 8.0.18-1.el7 mysql80-community 38 M
mysql-community-common x86_64 8.0.18-1.el7 mysql80-community 597 k

事务概要
======================================================================================
安装 3 软件包 (+3 依赖软件包)

总下载量:473 M
Is this ok [y/d/N]: y
Downloading packages:
(1/6): libaio-0.3.109-13.el7.x86_64.rpm | 24 kB 00:00:00
warning: /var/cache/yum/x86_64/7/mysql80-community/packages/mysql-community-common-8.0.18-1.el7.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 5072e1f5: NOKEY
mysql-community-common-8.0.18-1.el7.x86_64.rpm 的公钥尚未安装
(2/6): mysql-community-common-8.0.18-1.el7.x86_64.rpm | 597 kB 00:00:01
(3/6): mysql-community-libs-8.0.18-1.el7.x86_64.rpm | 3.7 MB 00:00:01
(4/6): mysql-community-libs-compat-8.0.18-1.el7.x86_64.rpm | 1.3 MB 00:00:04
(5/6): mysql-community-client-8.0.18-1.el7.x86_64.rpm | 38 MB 00:00:08
(6/6): mysql-community-server-8.0.18-1.el7.x86_64.rpm | 429 MB 00:05:18
--------------------------------------------------------------------------------------
总计 1.5 MB/s | 473 MB 05:26
从 file:///etc/pki/rpm-gpg/RPM-GPG-KEY-mysql 检索密钥
导入 GPG key 0x5072E1F5:
用户ID : "MySQL Release Engineering <mysql-build@oss.oracle.com>"
指纹 : a4a9 4068 76fc bd3c 4567 70c8 8c71 8d3b 5072 e1f5
软件包 : mysql80-community-release-el7-3.noarch (installed)
来自 : /etc/pki/rpm-gpg/RPM-GPG-KEY-mysql
是否继续?[y/N]:y
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
警告:RPM 数据库已被非 yum 程序修改。
正在安装 : mysql-community-common-8.0.18-1.el7.x86_64 1/7
正在安装 : mysql-community-libs-8.0.18-1.el7.x86_64 2/7
正在安装 : mysql-community-client-8.0.18-1.el7.x86_64 3/7
正在安装 : libaio-0.3.109-13.el7.x86_64 4/7
正在安装 : mysql-community-server-8.0.18-1.el7.x86_64 5/7
正在安装 : mysql-community-libs-compat-8.0.18-1.el7.x86_64 6/7
正在删除 : 1:mariadb-libs-5.5.60-1.el7_5.x86_64 7/7
验证中 : mysql-community-client-8.0.18-1.el7.x86_64 1/7
验证中 : mysql-community-common-8.0.18-1.el7.x86_64 2/7
验证中 : mysql-community-server-8.0.18-1.el7.x86_64 3/7
验证中 : mysql-community-libs-8.0.18-1.el7.x86_64 4/7
验证中 : mysql-community-libs-compat-8.0.18-1.el7.x86_64 5/7
验证中 : libaio-0.3.109-13.el7.x86_64 6/7
验证中 : 1:mariadb-libs-5.5.60-1.el7_5.x86_64 7/7

已安装:
mysql-community-libs.x86_64 0:8.0.18-1.el7
mysql-community-libs-compat.x86_64 0:8.0.18-1.el7
mysql-community-server.x86_64 0:8.0.18-1.el7

作为依赖被安装:
libaio.x86_64 0:0.3.109-13.el7
mysql-community-client.x86_64 0:8.0.18-1.el7
mysql-community-common.x86_64 0:8.0.18-1.el7

替代:
mariadb-libs.x86_64 1:5.5.60-1.el7_5

完毕!
[root@skyqin mysql]# systemctl start mysqld
[root@skyqin mysql]# systemctl enable mysqld
[root@skyqin mysql]# systemctl status mysqld
● mysqld.service - MySQL Server
Loaded: loaded (/usr/lib/systemd/system/mysqld.service; enabled; vendor preset: disabled)
Active: active (running) since 日 2019-11-03 13:11:41 CST; 2min 16s ago
Docs: man:mysqld(8)
http://dev.mysql.com/doc/refman/en/using-systemd.html
Main PID: 1803 (mysqld)
Status: "Server is operational"
CGroup: /system.slice/mysqld.service
└─1803 /usr/sbin/mysqld

11月 03 13:11:32 skyqin systemd[1]: Starting MySQL Server...
11月 03 13:11:41 skyqin systemd[1]: Started MySQL Server.
[root@skyqin mysql]# vim /var/log/mysqld.log
[root@skyqin mysql]# mysql -uroot -p
Enter password:
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 8
Server version: 8.0.18

Copyright (c) 2000, 2019, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> mysql> ALTER USER root@localhost IDENTIFIED BY 'Password/';
ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'mysql> ALTER USER root@localhost IDENTIFIED BY 'Password/'' at line 1
mysql> ALTER USER root@localhost IDENTIFIED BY 'Password/';
Query OK, 0 rows affected (0.01 sec)

mysql> create database typecho;
Query OK, 1 row affected (0.01 sec)

mysql> grant all privileges on typecho.* to typecho@localhost identified by 'Password/';
ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'identified by 'Password/'' at line 1
mysql> grant all privileges on typecho.* to typecho@localhost identified by 'Typecho1239/';
ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'identified by 'Typecho1239/'' at line 1
mysql> CREATE USER 'typecho'@'localhost' IDENTIFIED BY 'Password/';
Query OK, 0 rows affected (0.00 sec)

mysql> exit
Bye
[root@skyqin mysql]# mysql -u typecho -p
Enter password:
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 9
Server version: 8.0.18 MySQL Community Server - GPL

Copyright (c) 2000, 2019, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> show databases
-> ;
+--------------------+
| Database |
+--------------------+
| information_schema |
+--------------------+
1 row in set (0.12 sec)

mysql> creat database typecho;
ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'creat database typecho' at line 1
mysql> create database typecho;
ERROR 1044 (42000): Access denied for user 'typecho'@'localhost' to database 'typecho'
mysql> exit
Bye
[root@skyqin mysql]# mysql -u root -p
Enter password:
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 10
Server version: 8.0.18 MySQL Community Server - GPL

Copyright (c) 2000, 2019, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> grant all privileges on typecho.* to 'typecho'@'localhost';
Query OK, 0 rows affected (0.01 sec)

mysql> flush privileges;
Query OK, 0 rows affected (0.00 sec)

mysql> exit
Bye
[root@skyqin mysql]# mysql -u typecho -p
Enter password:
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 11
Server version: 8.0.18 MySQL Community Server - GPL

Copyright (c) 2000, 2019, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> show databases;
+--------------------+
| Database |
+--------------------+
| information_schema |
| typecho |
+--------------------+
2 rows in set (0.00 sec)

mysql> exit
Bye
[root@skyqin mysql]# yum install php
已加载插件:fastestmirror
Loading mirror speeds from cached hostfile
正在解决依赖关系
--> 正在检查事务
---> 软件包 php.x86_64.0.5.4.16-46.1.el7_7 将被 安装
--> 正在处理依赖关系 php-common(x86-64) = 5.4.16-46.1.el7_7,它被软件包 php-5.4.16-46.1.el7_7.x86_64 需要
--> 正在处理依赖关系 php-cli(x86-64) = 5.4.16-46.1.el7_7,它被软件包 php-5.4.16-46.1.el7_7.x86_64 需要
--> 正在检查事务
---> 软件包 php-cli.x86_64.0.5.4.16-46.1.el7_7 将被 安装
---> 软件包 php-common.x86_64.0.5.4.16-46.1.el7_7 将被 安装
--> 正在处理依赖关系 libzip.so.2()(64bit),它被软件包 php-common-5.4.16-46.1.el7_7.x86_64 需要
--> 正在检查事务
---> 软件包 libzip.x86_64.0.0.10.1-8.el7 将被 安装
--> 解决依赖关系完成

依赖关系解决

======================================================================================
Package 架构 版本 源 大小
======================================================================================
正在安装:
php x86_64 5.4.16-46.1.el7_7 updates 1.4 M
为依赖而安装:
libzip x86_64 0.10.1-8.el7 base 48 k
php-cli x86_64 5.4.16-46.1.el7_7 updates 2.7 M
php-common x86_64 5.4.16-46.1.el7_7 updates 565 k

事务概要
======================================================================================
安装 1 软件包 (+3 依赖软件包)

总下载量:4.7 M
安装大小:17 M
Is this ok [y/d/N]: y
Downloading packages:
(1/4): libzip-0.10.1-8.el7.x86_64.rpm | 48 kB 00:00:00
(2/4): php-5.4.16-46.1.el7_7.x86_64.rpm | 1.4 MB 00:00:00
(3/4): php-cli-5.4.16-46.1.el7_7.x86_64.rpm | 2.7 MB 00:00:00
(4/4): php-common-5.4.16-46.1.el7_7.x86_64.rpm | 565 kB 00:00:00
--------------------------------------------------------------------------------------
总计 15 MB/s | 4.7 MB 00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
正在安装 : libzip-0.10.1-8.el7.x86_64 1/4
正在安装 : php-common-5.4.16-46.1.el7_7.x86_64 2/4
正在安装 : php-cli-5.4.16-46.1.el7_7.x86_64 3/4
正在安装 : php-5.4.16-46.1.el7_7.x86_64 4/4
验证中 : php-common-5.4.16-46.1.el7_7.x86_64 1/4
验证中 : php-cli-5.4.16-46.1.el7_7.x86_64 2/4
验证中 : libzip-0.10.1-8.el7.x86_64 3/4
验证中 : php-5.4.16-46.1.el7_7.x86_64 4/4

已安装:
php.x86_64 0:5.4.16-46.1.el7_7

作为依赖被安装:
libzip.x86_64 0:0.10.1-8.el7 php-cli.x86_64 0:5.4.16-46.1.el7_7
php-common.x86_64 0:5.4.16-46.1.el7_7

完毕!
[root@skyqin mysql]# yum install php-mysql
已加载插件:fastestmirror
Loading mirror speeds from cached hostfile
正在解决依赖关系
--> 正在检查事务
---> 软件包 php-mysql.x86_64.0.5.4.16-46.1.el7_7 将被 安装
--> 正在处理依赖关系 php-pdo(x86-64) = 5.4.16-46.1.el7_7,它被软件包 php-mysql-5.4.16-46.1.el7_7.x86_64 需要
--> 正在检查事务
---> 软件包 php-pdo.x86_64.0.5.4.16-46.1.el7_7 将被 安装
--> 解决依赖关系完成

依赖关系解决

======================================================================================
Package 架构 版本 源 大小
======================================================================================
正在安装:
php-mysql x86_64 5.4.16-46.1.el7_7 updates 101 k
为依赖而安装:
php-pdo x86_64 5.4.16-46.1.el7_7 updates 99 k

事务概要
======================================================================================
安装 1 软件包 (+1 依赖软件包)

总下载量:201 k
安装大小:424 k
Is this ok [y/d/N]: y
Downloading packages:
(1/2): php-pdo-5.4.16-46.1.el7_7.x86_64.rpm | 99 kB 00:00:00
(2/2): php-mysql-5.4.16-46.1.el7_7.x86_64.rpm | 101 kB 00:00:00
--------------------------------------------------------------------------------------
总计 1.3 MB/s | 201 kB 00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
正在安装 : php-pdo-5.4.16-46.1.el7_7.x86_64 1/2
正在安装 : php-mysql-5.4.16-46.1.el7_7.x86_64 2/2
验证中 : php-mysql-5.4.16-46.1.el7_7.x86_64 1/2
验证中 : php-pdo-5.4.16-46.1.el7_7.x86_64 2/2

已安装:
php-mysql.x86_64 0:5.4.16-46.1.el7_7

作为依赖被安装:
php-pdo.x86_64 0:5.4.16-46.1.el7_7

完毕!
[root@skyqin mysql]# yum search php-
已加载插件:fastestmirror
Loading mirror speeds from cached hostfile
================================= N/S matched: php- ==================================

>>>>>>>>>>>此处的显示略过,实在太长<<<<<<<<<<

名称和简介匹配 only,使用“search all”试试。
[root@skyqin mysql]# yum -y install php-gd php-ldap php-odbc php-pear php-xml php-xmlrpc php-mbstring php-snmp php-soap curl curl-devel
已加载插件:fastestmirror
Loading mirror speeds from cached hostfile
正在解决依赖关系
--> 正在检查事务
---> 软件包 curl.x86_64.0.7.29.0-51.el7 将被 升级
---> 软件包 curl.x86_64.0.7.29.0-54.el7 将被 更新
--> 正在处理依赖关系 libcurl = 7.29.0-54.el7,它被软件包 curl-7.29.0-54.el7.x86_64 需要
---> 软件包 libcurl-devel.x86_64.0.7.29.0-54.el7 将被 安装
base/7/x86_64/filelists_db | 7.3 MB 00:00:00
updates/7/x86_64/filelists_db | 2.1 MB 00:00:00
---> 软件包 php-gd.x86_64.0.5.4.16-46.1.el7_7 将被 安装
--> 正在处理依赖关系 libjpeg.so.62(LIBJPEG_6.2)(64bit),它被软件包 php-gd-5.4.16-46.1.el7_7.x86_64 需要
--> 正在处理依赖关系 libt1.so.5()(64bit),它被软件包 php-gd-5.4.16-46.1.el7_7.x86_64 需要
--> 正在处理依赖关系 libjpeg.so.62()(64bit),它被软件包 php-gd-5.4.16-46.1.el7_7.x86_64 需要
--> 正在处理依赖关系 libXpm.so.4()(64bit),它被软件包 php-gd-5.4.16-46.1.el7_7.x86_64 需要
--> 正在处理依赖关系 libX11.so.6()(64bit),它被软件包 php-gd-5.4.16-46.1.el7_7.x86_64 需要
---> 软件包 php-ldap.x86_64.0.5.4.16-46.1.el7_7 将被 安装
---> 软件包 php-mbstring.x86_64.0.5.4.16-46.1.el7_7 将被 安装
---> 软件包 php-odbc.x86_64.0.5.4.16-46.1.el7_7 将被 安装
--> 正在处理依赖关系 libodbc.so.2()(64bit),它被软件包 php-odbc-5.4.16-46.1.el7_7.x86_64 需要
---> 软件包 php-pear.noarch.1.1.9.4-21.el7 将被 安装
--> 正在处理依赖关系 php-posix,它被软件包 1:php-pear-1.9.4-21.el7.noarch 需要
---> 软件包 php-snmp.x86_64.0.5.4.16-46.1.el7_7 将被 安装
--> 正在处理依赖关系 net-snmp,它被软件包 php-snmp-5.4.16-46.1.el7_7.x86_64 需要
--> 正在处理依赖关系 libnetsnmp.so.31()(64bit),它被软件包 php-snmp-5.4.16-46.1.el7_7.x86_64 需要
---> 软件包 php-soap.x86_64.0.5.4.16-46.1.el7_7 将被 安装
---> 软件包 php-xml.x86_64.0.5.4.16-46.1.el7_7 将被 安装
--> 正在处理依赖关系 libxslt.so.1(LIBXML2_1.0.24)(64bit),它被软件包 php-xml-5.4.16-46.1.el7_7.x86_64 需要
--> 正在处理依赖关系 libxslt.so.1(LIBXML2_1.0.22)(64bit),它被软件包 php-xml-5.4.16-46.1.el7_7.x86_64 需要
--> 正在处理依赖关系 libxslt.so.1(LIBXML2_1.0.18)(64bit),它被软件包 php-xml-5.4.16-46.1.el7_7.x86_64 需要
--> 正在处理依赖关系 libxslt.so.1(LIBXML2_1.0.13)(64bit),它被软件包 php-xml-5.4.16-46.1.el7_7.x86_64 需要
--> 正在处理依赖关系 libxslt.so.1(LIBXML2_1.0.11)(64bit),它被软件包 php-xml-5.4.16-46.1.el7_7.x86_64 需要
--> 正在处理依赖关系 libxslt.so.1()(64bit),它被软件包 php-xml-5.4.16-46.1.el7_7.x86_64 需要
--> 正在处理依赖关系 libexslt.so.0()(64bit),它被软件包 php-xml-5.4.16-46.1.el7_7.x86_64 需要
---> 软件包 php-xmlrpc.x86_64.0.5.4.16-46.1.el7_7 将被 安装
--> 正在检查事务
---> 软件包 libX11.x86_64.0.1.6.7-2.el7 将被 安装
--> 正在处理依赖关系 libX11-common >= 1.6.7-2.el7,它被软件包 libX11-1.6.7-2.el7.x86_64 需要
--> 正在处理依赖关系 libxcb.so.1()(64bit),它被软件包 libX11-1.6.7-2.el7.x86_64 需要
---> 软件包 libXpm.x86_64.0.3.5.12-1.el7 将被 安装
---> 软件包 libcurl.x86_64.0.7.29.0-51.el7 将被 升级
---> 软件包 libcurl.x86_64.0.7.29.0-54.el7 将被 更新
---> 软件包 libjpeg-turbo.x86_64.0.1.2.90-8.el7 将被 安装
---> 软件包 libxslt.x86_64.0.1.1.28-5.el7 将被 安装
---> 软件包 net-snmp.x86_64.1.5.7.2-43.el7 将被 安装
--> 正在处理依赖关系 net-snmp-agent-libs = 1:5.7.2-43.el7,它被软件包 1:net-snmp-5.7.2-43.el7.x86_64 需要
--> 正在处理依赖关系 perl(Data::Dumper),它被软件包 1:net-snmp-5.7.2-43.el7.x86_64 需要
--> 正在处理依赖关系 libnetsnmptrapd.so.31()(64bit),它被软件包 1:net-snmp-5.7.2-43.el7.x86_64 需要
--> 正在处理依赖关系 libnetsnmpmibs.so.31()(64bit),它被软件包 1:net-snmp-5.7.2-43.el7.x86_64 需要
--> 正在处理依赖关系 libnetsnmpagent.so.31()(64bit),它被软件包 1:net-snmp-5.7.2-43.el7.x86_64 需要
---> 软件包 net-snmp-libs.x86_64.1.5.7.2-43.el7 将被 安装
---> 软件包 php-process.x86_64.0.5.4.16-46.1.el7_7 将被 安装
---> 软件包 t1lib.x86_64.0.5.1.2-14.el7 将被 安装
---> 软件包 unixODBC.x86_64.0.2.3.1-14.el7 将被 安装
--> 正在处理依赖关系 libltdl.so.7()(64bit),它被软件包 unixODBC-2.3.1-14.el7.x86_64 需要
--> 正在检查事务
---> 软件包 libX11-common.noarch.0.1.6.7-2.el7 将被 安装
---> 软件包 libtool-ltdl.x86_64.0.2.4.2-22.el7_3 将被 安装
---> 软件包 libxcb.x86_64.0.1.13-1.el7 将被 安装
--> 正在处理依赖关系 libXau.so.6()(64bit),它被软件包 libxcb-1.13-1.el7.x86_64 需要
---> 软件包 net-snmp-agent-libs.x86_64.1.5.7.2-43.el7 将被 安装
---> 软件包 perl-Data-Dumper.x86_64.0.2.145-3.el7 将被 安装
--> 正在检查事务
---> 软件包 libXau.x86_64.0.1.0.8-2.1.el7 将被 安装
--> 解决依赖关系完成

依赖关系解决

======================================================================================
Package 架构 版本 源 大小
======================================================================================
正在安装:
libcurl-devel x86_64 7.29.0-54.el7 base 302 k
php-gd x86_64 5.4.16-46.1.el7_7 updates 128 k
php-ldap x86_64 5.4.16-46.1.el7_7 updates 53 k
php-mbstring x86_64 5.4.16-46.1.el7_7 updates 505 k
php-odbc x86_64 5.4.16-46.1.el7_7 updates 66 k
php-pear noarch 1:1.9.4-21.el7 base 357 k
php-snmp x86_64 5.4.16-46.1.el7_7 updates 53 k
php-soap x86_64 5.4.16-46.1.el7_7 updates 159 k
php-xml x86_64 5.4.16-46.1.el7_7 updates 126 k
php-xmlrpc x86_64 5.4.16-46.1.el7_7 updates 68 k
正在更新:
curl x86_64 7.29.0-54.el7 base 270 k
为依赖而安装:
libX11 x86_64 1.6.7-2.el7 base 607 k
libX11-common noarch 1.6.7-2.el7 base 164 k
libXau x86_64 1.0.8-2.1.el7 base 29 k
libXpm x86_64 3.5.12-1.el7 base 55 k
libjpeg-turbo x86_64 1.2.90-8.el7 base 135 k
libtool-ltdl x86_64 2.4.2-22.el7_3 base 49 k
libxcb x86_64 1.13-1.el7 base 214 k
libxslt x86_64 1.1.28-5.el7 base 242 k
net-snmp x86_64 1:5.7.2-43.el7 base 331 k
net-snmp-agent-libs x86_64 1:5.7.2-43.el7 base 706 k
net-snmp-libs x86_64 1:5.7.2-43.el7 base 750 k
perl-Data-Dumper x86_64 2.145-3.el7 base 47 k
php-process x86_64 5.4.16-46.1.el7_7 updates 56 k
t1lib x86_64 5.1.2-14.el7 base 166 k
unixODBC x86_64 2.3.1-14.el7 base 413 k
为依赖而更新:
libcurl x86_64 7.29.0-54.el7 base 222 k

事务概要
======================================================================================
安装 10 软件包 (+15 依赖软件包)
升级 1 软件包 (+ 1 依赖软件包)

总下载量:6.1 M
Downloading packages:
Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
(1/27): curl-7.29.0-54.el7.x86_64.rpm | 270 kB 00:00:00
(2/27): libX11-common-1.6.7-2.el7.noarch.rpm | 164 kB 00:00:00
(3/27): libXau-1.0.8-2.1.el7.x86_64.rpm | 29 kB 00:00:00
(4/27): libXpm-3.5.12-1.el7.x86_64.rpm | 55 kB 00:00:00
(5/27): libX11-1.6.7-2.el7.x86_64.rpm | 607 kB 00:00:00
(6/27): libcurl-7.29.0-54.el7.x86_64.rpm | 222 kB 00:00:00
(7/27): libcurl-devel-7.29.0-54.el7.x86_64.rpm | 302 kB 00:00:00
(8/27): libtool-ltdl-2.4.2-22.el7_3.x86_64.rpm | 49 kB 00:00:00
(9/27): libjpeg-turbo-1.2.90-8.el7.x86_64.rpm | 135 kB 00:00:00
(10/27): libxcb-1.13-1.el7.x86_64.rpm | 214 kB 00:00:00
(11/27): libxslt-1.1.28-5.el7.x86_64.rpm | 242 kB 00:00:00
(12/27): net-snmp-5.7.2-43.el7.x86_64.rpm | 331 kB 00:00:00
(13/27): net-snmp-agent-libs-5.7.2-43.el7.x86_64.rpm | 706 kB 00:00:00
(14/27): perl-Data-Dumper-2.145-3.el7.x86_64.rpm | 47 kB 00:00:00
(15/27): net-snmp-libs-5.7.2-43.el7.x86_64.rpm | 750 kB 00:00:00
(16/27): php-ldap-5.4.16-46.1.el7_7.x86_64.rpm | 53 kB 00:00:00
(17/27): php-gd-5.4.16-46.1.el7_7.x86_64.rpm | 128 kB 00:00:00
(18/27): php-odbc-5.4.16-46.1.el7_7.x86_64.rpm | 66 kB 00:00:00
(19/27): php-process-5.4.16-46.1.el7_7.x86_64.rpm | 56 kB 00:00:00
(20/27): php-mbstring-5.4.16-46.1.el7_7.x86_64.rpm | 505 kB 00:00:00
(21/27): php-snmp-5.4.16-46.1.el7_7.x86_64.rpm | 53 kB 00:00:00
(22/27): php-xml-5.4.16-46.1.el7_7.x86_64.rpm | 126 kB 00:00:00
(23/27): php-xmlrpc-5.4.16-46.1.el7_7.x86_64.rpm | 68 kB 00:00:00
(24/27): php-soap-5.4.16-46.1.el7_7.x86_64.rpm | 159 kB 00:00:00
(25/27): php-pear-1.9.4-21.el7.noarch.rpm | 357 kB 00:00:00
(26/27): t1lib-5.1.2-14.el7.x86_64.rpm | 166 kB 00:00:00
(27/27): unixODBC-2.3.1-14.el7.x86_64.rpm | 413 kB 00:00:00
--------------------------------------------------------------------------------------
总计 4.4 MB/s | 6.1 MB 00:01
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
正在安装 : 1:net-snmp-libs-5.7.2-43.el7.x86_64 1/29
正在更新 : libcurl-7.29.0-54.el7.x86_64 2/29
正在安装 : 1:net-snmp-agent-libs-5.7.2-43.el7.x86_64 3/29
正在安装 : libXau-1.0.8-2.1.el7.x86_64 4/29
正在安装 : libxcb-1.13-1.el7.x86_64 5/29
正在安装 : libxslt-1.1.28-5.el7.x86_64 6/29
正在安装 : php-xml-5.4.16-46.1.el7_7.x86_64 7/29
正在安装 : libjpeg-turbo-1.2.90-8.el7.x86_64 8/29
正在安装 : libX11-common-1.6.7-2.el7.noarch 9/29
正在安装 : libX11-1.6.7-2.el7.x86_64 10/29
正在安装 : libXpm-3.5.12-1.el7.x86_64 11/29
正在安装 : t1lib-5.1.2-14.el7.x86_64 12/29
正在安装 : libtool-ltdl-2.4.2-22.el7_3.x86_64 13/29
正在安装 : unixODBC-2.3.1-14.el7.x86_64 14/29
正在安装 : perl-Data-Dumper-2.145-3.el7.x86_64 15/29
正在安装 : 1:net-snmp-5.7.2-43.el7.x86_64 16/29
正在安装 : php-process-5.4.16-46.1.el7_7.x86_64 17/29
正在安装 : 1:php-pear-1.9.4-21.el7.noarch 18/29
正在安装 : php-snmp-5.4.16-46.1.el7_7.x86_64 19/29
正在安装 : php-odbc-5.4.16-46.1.el7_7.x86_64 20/29
正在安装 : php-gd-5.4.16-46.1.el7_7.x86_64 21/29
正在更新 : curl-7.29.0-54.el7.x86_64 22/29
正在安装 : libcurl-devel-7.29.0-54.el7.x86_64 23/29
正在安装 : php-mbstring-5.4.16-46.1.el7_7.x86_64 24/29
正在安装 : php-ldap-5.4.16-46.1.el7_7.x86_64 25/29
正在安装 : php-xmlrpc-5.4.16-46.1.el7_7.x86_64 26/29
正在安装 : php-soap-5.4.16-46.1.el7_7.x86_64 27/29
清理 : curl-7.29.0-51.el7.x86_64 28/29
清理 : libcurl-7.29.0-51.el7.x86_64 29/29
验证中 : php-process-5.4.16-46.1.el7_7.x86_64 1/29
验证中 : unixODBC-2.3.1-14.el7.x86_64 2/29
验证中 : php-odbc-5.4.16-46.1.el7_7.x86_64 3/29
验证中 : 1:net-snmp-5.7.2-43.el7.x86_64 4/29
验证中 : php-snmp-5.4.16-46.1.el7_7.x86_64 5/29
验证中 : 1:net-snmp-libs-5.7.2-43.el7.x86_64 6/29
验证中 : perl-Data-Dumper-2.145-3.el7.x86_64 7/29
验证中 : libtool-ltdl-2.4.2-22.el7_3.x86_64 8/29
验证中 : libX11-1.6.7-2.el7.x86_64 9/29
验证中 : libX11-common-1.6.7-2.el7.noarch 10/29
验证中 : libxcb-1.13-1.el7.x86_64 11/29
验证中 : libXpm-3.5.12-1.el7.x86_64 12/29
验证中 : libjpeg-turbo-1.2.90-8.el7.x86_64 13/29
验证中 : t1lib-5.1.2-14.el7.x86_64 14/29
验证中 : libxslt-1.1.28-5.el7.x86_64 15/29
验证中 : libcurl-7.29.0-54.el7.x86_64 16/29
验证中 : curl-7.29.0-54.el7.x86_64 17/29
验证中 : libcurl-devel-7.29.0-54.el7.x86_64 18/29
验证中 : php-soap-5.4.16-46.1.el7_7.x86_64 19/29
验证中 : php-xmlrpc-5.4.16-46.1.el7_7.x86_64 20/29
验证中 : php-ldap-5.4.16-46.1.el7_7.x86_64 21/29
验证中 : php-xml-5.4.16-46.1.el7_7.x86_64 22/29
验证中 : 1:net-snmp-agent-libs-5.7.2-43.el7.x86_64 23/29
验证中 : libXau-1.0.8-2.1.el7.x86_64 24/29
验证中 : 1:php-pear-1.9.4-21.el7.noarch 25/29
验证中 : php-gd-5.4.16-46.1.el7_7.x86_64 26/29
验证中 : php-mbstring-5.4.16-46.1.el7_7.x86_64 27/29
验证中 : curl-7.29.0-51.el7.x86_64 28/29
验证中 : libcurl-7.29.0-51.el7.x86_64 29/29

已安装:
libcurl-devel.x86_64 0:7.29.0-54.el7 php-gd.x86_64 0:5.4.16-46.1.el7_7
php-ldap.x86_64 0:5.4.16-46.1.el7_7 php-mbstring.x86_64 0:5.4.16-46.1.el7_7
php-odbc.x86_64 0:5.4.16-46.1.el7_7 php-pear.noarch 1:1.9.4-21.el7
php-snmp.x86_64 0:5.4.16-46.1.el7_7 php-soap.x86_64 0:5.4.16-46.1.el7_7
php-xml.x86_64 0:5.4.16-46.1.el7_7 php-xmlrpc.x86_64 0:5.4.16-46.1.el7_7

作为依赖被安装:
libX11.x86_64 0:1.6.7-2.el7 libX11-common.noarch 0:1.6.7-2.el7
libXau.x86_64 0:1.0.8-2.1.el7 libXpm.x86_64 0:3.5.12-1.el7
libjpeg-turbo.x86_64 0:1.2.90-8.el7 libtool-ltdl.x86_64 0:2.4.2-22.el7_3
libxcb.x86_64 0:1.13-1.el7 libxslt.x86_64 0:1.1.28-5.el7
net-snmp.x86_64 1:5.7.2-43.el7 net-snmp-agent-libs.x86_64 1:5.7.2-43.el7
net-snmp-libs.x86_64 1:5.7.2-43.el7 perl-Data-Dumper.x86_64 0:2.145-3.el7
php-process.x86_64 0:5.4.16-46.1.el7_7 t1lib.x86_64 0:5.1.2-14.el7
unixODBC.x86_64 0:2.3.1-14.el7

更新完毕:
curl.x86_64 0:7.29.0-54.el7

作为依赖被升级:
libcurl.x86_64 0:7.29.0-54.el7

完毕!
[root@skyqin mysql]# cd /var/www/html/
[root@skyqin html]# vim info.php
[root@skyqin html]# systemctl restart httpd
Job for httpd.service failed because the control process exited with error code. See "systemctl status httpd.service" and "journalctl -xe" for details.
[root@skyqin html]# systemctl status httpd
● httpd.service - The Apache HTTP Server
Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since 日 2019-11-03 13:42:59 CST; 26s ago
Docs: man:httpd(8)
man:apachectl(8)
Process: 11839 ExecStop=/bin/kill -WINCH ${MAINPID} (code=exited, status=1/FAILURE)
Process: 11838 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE)
Main PID: 11838 (code=exited, status=1/FAILURE)

11月 03 13:42:59 skyqin httpd[11838]: AH00558: httpd: Could not reliably determi...ge
11月 03 13:42:59 skyqin httpd[11838]: (99)Cannot assign requested address: AH000...80
11月 03 13:42:59 skyqin httpd[11838]: no listening sockets available, shutting down
11月 03 13:42:59 skyqin httpd[11838]: AH00015: Unable to open logs
11月 03 13:42:59 skyqin systemd[1]: httpd.service: main process exited, code=exi...RE
11月 03 13:42:59 skyqin kill[11839]: kill: cannot find process ""
11月 03 13:42:59 skyqin systemd[1]: httpd.service: control process exited, code=...=1
11月 03 13:42:59 skyqin systemd[1]: Failed to start The Apache HTTP Server.
11月 03 13:42:59 skyqin systemd[1]: Unit httpd.service entered failed state.
11月 03 13:42:59 skyqin systemd[1]: httpd.service failed.
Hint: Some lines were ellipsized, use -l to show in full.
[root@skyqin html]# systemctl stop httpd
[root@skyqin html]# systemctl start httpd
Job for httpd.service failed because the control process exited with error code. See "systemctl status httpd.service" and "journalctl -xe" for details.
[root@skyqin html]# netstat -lnp | grep 80
tcp6 0 0 :::3306 :::* LISTEN 1803/mysqld
tcp6 0 0 :::33060 :::* LISTEN 1803/mysqld
unix 2 [ ACC ] STREAM LISTENING 23570 1803/mysqld /var/run/mysqld/mysqlx.sock
unix 2 [ ACC ] STREAM LISTENING 23564 1803/mysqld /var/lib/mysql/mysql.sock
[root@skyqin html]# netstat -lnp | grep 80
tcp6 0 0 :::3306 :::* LISTEN 1803/mysqld
tcp6 0 0 :::33060 :::* LISTEN 1803/mysqld
unix 2 [ ACC ] STREAM LISTENING 23570 1803/mysqld /var/run/mysqld/mysqlx.sock
unix 2 [ ACC ] STREAM LISTENING 23564 1803/mysqld /var/lib/mysql/mysql.sock
[root@skyqin html]# vim /etc/httpd/conf/httpd.conf
[root@skyqin html]# systemctl start httpd
[root@skyqin html]# cd ~
[root@skyqin ~]# mkdir typecho
[root@skyqin ~]# cd typecho
[root@skyqin typecho]# wget http://typecho.org/downloads/1.1-17.10.30-release.tar.gz
--2019-11-03 13:59:11-- http://typecho.org/downloads/1.1-17.10.30-release.tar.gz
正在解析主机 typecho.org (typecho.org)... 35.198.239.0
正在连接 typecho.org (typecho.org)|35.198.239.0|:80... 已连接。
已发出 HTTP 请求,正在等待回应... 200 OK
长度:487445 (476K) [application/octet-stream]
正在保存至: “1.1-17.10.30-release.tar.gz”

100%[============================================>] 487,445 1.22MB/s 用时 0.4s

2019-11-03 13:59:12 (1.22 MB/s) - 已保存 “1.1-17.10.30-release.tar.gz” [487445/487445])

[root@skyqin typecho]# ls
1.1-17.10.30-release.tar.gz
[root@skyqin typecho]# tar -xzvf 1.1-17.10.30-release.tar.gz

》》》》》》》》》解压过程略过《《《《《《《《《

[root@skyqin typecho]# ls
1.1-17.10.30-release.tar.gz build
[root@skyqin typecho]# cd /var/www/html/
[root@skyqin html]# ls
info.php
[root@skyqin html]# mv info.php info.php.bak
[root@skyqin html]# ls
info.php.bak
[root@skyqin html]# cd~
bash: cd~: 未找到命令
[root@skyqin html]# cd ~
[root@skyqin ~]# cd typecho
[root@skyqin typecho]# cp -R build/* /var/www/html/
[root@skyqin typecho]# systemctl status mysqld
● mysqld.service - MySQL Server
Loaded: loaded (/usr/lib/systemd/system/mysqld.service; enabled; vendor preset: disabled)
Active: active (running) since 日 2019-11-03 13:11:41 CST; 55min ago
Docs: man:mysqld(8)
http://dev.mysql.com/doc/refman/en/using-systemd.html
Main PID: 1803 (mysqld)
Status: "Server is operational"
CGroup: /system.slice/mysqld.service
└─1803 /usr/sbin/mysqld

11月 03 13:11:32 skyqin systemd[1]: Starting MySQL Server...
11月 03 13:11:41 skyqin systemd[1]: Started MySQL Server.
[root@skyqin typecho]# systemctl restart mysqld
[root@skyqin typecho]# mysql -u typecho -p
Enter password:
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 10
Server version: 8.0.18 MySQL Community Server - GPL

Copyright (c) 2000, 2019, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> show databases;
+--------------------+
| Database |
+--------------------+
| information_schema |
| typecho |
+--------------------+
2 rows in set (0.00 sec)

mysql> ALTER USER 'typecho'@'localhost' IDENTIFIED WITH mysql_native_password BY 'Password/';
ERROR 1227 (42000): Access denied; you need (at least one of) the CREATE USER privilege(s) for this operation
mysql> exit
Bye
[root@skyqin typecho]# mysql -u root -p
Enter password:
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 12
Server version: 8.0.18 MySQL Community Server - GPL

Copyright (c) 2000, 2019, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> ALTER USER 'typecho'@'localhost' IDENTIFIED WITH mysql_native_password BY 'Password/';
Query OK, 0 rows affected (0.01 sec)

mysql> exit
Bye
[root@skyqin typecho]# cd /var/www/html/
[root@skyqin html]# ls
admin index.php info.php.bak install install.php LICENSE.txt usr var
[root@skyqin html]# vim config.inc.php
[root@skyqin html]# vim .htaccess
[root@skyqin html]# vim /etc/httpd/conf/httpd.conf
[root@skyqin html]# vim /etc/httpd/conf/httpd.conf
[root@skyqin html]# vim /etc/httpd/conf/httpd.conf
[root@skyqin html]# cd /var/www/html
[root@skyqin html]# ls
admin index.php install LICENSE.txt var
config.inc.php info.php.bak install.php usr
[root@skyqin html]# vim .htaccess
[root@skyqin html]#
[root@skyqin html]# cp .htaccess /etc/httpd/.htaccess
[root@skyqin html]# a2enmod rewrite
bash: a2enmod: 未找到命令
[root@skyqin html]# sudo a2enmod rewrite
sudo: a2enmod:找不到命令
[root@skyqin html]# systemctl restart httpd
[root@skyqin html]#

1. https://blog.csdn.net/yangxjsun/article/details/82177297

2. https://www.cnblogs.com/luoliang/p/4045955.html

3. https://www.typechodev.com/servers/remove_index_for_apache.html